summaryrefslogtreecommitdiffstats
path: root/openwrt/package/motion/patches
diff options
context:
space:
mode:
authornico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>2006-03-27 20:36:45 +0000
committernico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>2006-03-27 20:36:45 +0000
commit74845c405d147fff026459f0f70c68c5b4287db2 (patch)
tree51f7836daff1a9016a7995a63a5eb161504efcff /openwrt/package/motion/patches
parentbd08843b081100546f520b6956dc3174ed5d5e1b (diff)
update motion package, add a patch to honor CPPFLAGS,
explicitely remove database support, add MD5SUMS, add dependency on libpthread in ipkg/control file, standardize. git-svn-id: svn://svn.openwrt.org/openwrt/trunk@3509 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'openwrt/package/motion/patches')
-rw-r--r--openwrt/package/motion/patches/02-honor_cppflags.patch20
1 files changed, 20 insertions, 0 deletions
diff --git a/openwrt/package/motion/patches/02-honor_cppflags.patch b/openwrt/package/motion/patches/02-honor_cppflags.patch
new file mode 100644
index 000000000..322fb772d
--- /dev/null
+++ b/openwrt/package/motion/patches/02-honor_cppflags.patch
@@ -0,0 +1,20 @@
+diff -ruN motion-3.2.5.1-old/Makefile.in motion-3.2.5.1-new/Makefile.in
+--- motion-3.2.5.1-old/Makefile.in 2006-03-07 22:52:49.000000000 +0100
++++ motion-3.2.5.1-new/Makefile.in 2006-03-27 22:04:34.000000000 +0200
+@@ -32,6 +32,7 @@
+ ################################################################################
+ CFLAGS = @CFLAGS@ -Wall -DVERSION=\"$(VERSION)\" -D_REENTRANT \
+ -Dsysconfdir=\"$(sysconfdir)\"
++CPPFLAGS = @CPPFLAGS@
+ LDFLAGS = @LDFLAGS@
+ LIBS = @LIBS@
+ VIDEO_OBJ = @VIDEO@
+@@ -115,7 +116,7 @@
+ ################################################################################
+ $(DEPEND_FILE): *.h $(SRC)
+ @echo "Generating dependencies, please wait..."
+- @$(CC) $(CFLAGS) -M $(SRC) > .tmp
++ @$(CC) $(CFLAGS) $(CPPFLAGS) -M $(SRC) > .tmp
+ @mv -f .tmp $(DEPEND_FILE)
+ @echo
+