summaryrefslogtreecommitdiffstats
path: root/openwrt/package/dropbear
diff options
context:
space:
mode:
authornico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-03-06 12:03:54 +0000
committernico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-03-06 12:03:54 +0000
commiteba4b4bcfc49afc8a3d1649751765f1e3285db65 (patch)
treea0d55a1af9452553547e40d42830c4669d9943d3 /openwrt/package/dropbear
parent89c4c9dca9c9b471f5e9361efa5f39cb8e80f392 (diff)
Add package install dependencies (don't install a package if it's already installed)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@315 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'openwrt/package/dropbear')
-rw-r--r--openwrt/package/dropbear/Makefile7
1 files changed, 5 insertions, 2 deletions
diff --git a/openwrt/package/dropbear/Makefile b/openwrt/package/dropbear/Makefile
index eec889dea..62d802e94 100644
--- a/openwrt/package/dropbear/Makefile
+++ b/openwrt/package/dropbear/Makefile
@@ -69,11 +69,14 @@ $(PACKAGE_DIR)/$(DROPBEAR_IPK): $(DROPBEAR_DIR)/$(DROPBEAR_BINARY)
chmod a+x $(DROPBEAR_IPK_DIR)/etc/init.d/S50dropbear
$(IPKG_BUILD) $(DROPBEAR_IPK_DIR) $(PACKAGE_DIR)
+$(IPKG_STATE_DIR)/info/dropbear.list: $(PACKAGE_DIR)/$(DROPBEAR_IPK)
+ $(IPKG) install $(PACKAGE_DIR)/$(DROPBEAR_IPK)
+
source: $(DL_DIR)/$(DROPBEAR_SOURCE)
prepare: $(DROPBEAR_DIR)/.patched
compile: $(PACKAGE_DIR)/$(DROPBEAR_IPK)
-install: compile
- $(IPKG) install $(PACKAGE_DIR)/$(DROPBEAR_IPK)
+install: $(IPKG_STATE_DIR)/info/dropbear.list
+
clean:
rm -rf $(DROPBEAR_DIR)
rm -f $(PACKAGE_DIR)/$(DROPBEAR_IPK)