summaryrefslogtreecommitdiffstats
path: root/openwrt/package/dropbear/Makefile
diff options
context:
space:
mode:
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-03-14 16:01:08 +0000
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-03-14 16:01:08 +0000
commit58520fdb29f9af5c17d850100b387f04a405d17d (patch)
tree2bb9703b91f5fbe49acfc9a3a265424e6c394113 /openwrt/package/dropbear/Makefile
parent61fc978d6717674c49a2fe8c03af85a01c97379d (diff)
add /etc/passwd with an empty root password for dropbear
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@370 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'openwrt/package/dropbear/Makefile')
-rw-r--r--openwrt/package/dropbear/Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/openwrt/package/dropbear/Makefile b/openwrt/package/dropbear/Makefile
index 62d802e94..83558a33c 100644
--- a/openwrt/package/dropbear/Makefile
+++ b/openwrt/package/dropbear/Makefile
@@ -55,6 +55,7 @@ $(DROPBEAR_DIR)/$(DROPBEAR_BINARY): $(DROPBEAR_DIR)/.configured
$(PACKAGE_DIR)/$(DROPBEAR_IPK): $(DROPBEAR_DIR)/$(DROPBEAR_BINARY)
$(SCRIPT_DIR)/make-ipkg-dir.sh $(DROPBEAR_IPK_DIR) dropbear.control $(DROPBEAR_VERSION)-1 $(ARCH)
+ cp dropbear.conffiles $(DROPBEAR_IPK_DIR)/CONTROL/conffiles
mkdir -p $(DROPBEAR_IPK_DIR)/usr/bin
mkdir -p $(DROPBEAR_IPK_DIR)/usr/sbin
install -m 755 $(DROPBEAR_DIR)/$(DROPBEAR_BINARY) \
@@ -65,6 +66,7 @@ $(PACKAGE_DIR)/$(DROPBEAR_IPK): $(DROPBEAR_DIR)/$(DROPBEAR_BINARY)
ln -sf ../sbin/dropbear $(DROPBEAR_IPK_DIR)/usr/bin/dropbearkey
ln -sf ../sbin/dropbear $(DROPBEAR_IPK_DIR)/usr/bin/dropbearconvert
mkdir -p $(DROPBEAR_IPK_DIR)/etc/init.d
+ cp ./files/passwd $(DROPBEAR_IPK_DIR)/etc
cp ./files/S50dropbear $(DROPBEAR_IPK_DIR)/etc/init.d/
chmod a+x $(DROPBEAR_IPK_DIR)/etc/init.d/S50dropbear
$(IPKG_BUILD) $(DROPBEAR_IPK_DIR) $(PACKAGE_DIR)