summaryrefslogtreecommitdiffstats
path: root/openwrt/package/base-files/Makefile
diff options
context:
space:
mode:
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>2006-04-05 02:09:22 +0000
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>2006-04-05 02:09:22 +0000
commit93701b2bec2b99d8113d8a6d9b97153e87a7e5aa (patch)
tree2a8ba6aa03cd4a2eaaa417fd47c30ebc71e73e5f /openwrt/package/base-files/Makefile
parent9ce1fe9aaa459cf48fcb1e89537cbe0456d7dfac (diff)
large init script cleanup and merge of whiterussian changes, new dnsmasq config handling
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@3588 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'openwrt/package/base-files/Makefile')
-rw-r--r--openwrt/package/base-files/Makefile12
1 files changed, 7 insertions, 5 deletions
diff --git a/openwrt/package/base-files/Makefile b/openwrt/package/base-files/Makefile
index 1fb0c1449..8517dcc68 100644
--- a/openwrt/package/base-files/Makefile
+++ b/openwrt/package/base-files/Makefile
@@ -55,23 +55,25 @@ $(IPKG_BASE):
$(CP) ./default/* $(IDIR_BASE)
$(SED) 's,$$R,r$(REV),g' $(IDIR_BASE)/etc/banner
$(SED) 's,$$S,$(BOARD)-$(KERNEL),g' $(IDIR_BASE)/etc/ipkg.conf
- mkdir -p $(IDIR_BASE)/sys
- mkdir -p $(IDIR_BASE)/jffs
mkdir -p $(IDIR_BASE)/dev
+ mkdir -p $(IDIR_BASE)/etc/crontabs
+ mkdir -p $(IDIR_BASE)/jffs
+ mkdir -p $(IDIR_BASE)/lib
+ mkdir -p $(IDIR_BASE)/mnt
mkdir -p $(IDIR_BASE)/proc
mkdir -p $(IDIR_BASE)/tmp
- mkdir -p $(IDIR_BASE)/lib
mkdir -p $(IDIR_BASE)/usr/lib
mkdir -p $(IDIR_BASE)/usr/bin
+ mkdir -p $(IDIR_BASE)/sys
+ mkdir -p $(IDIR_BASE)/www
ln -sf /tmp/resolv.conf $(IDIR_BASE)/etc/resolv.conf
ln -sf /proc/mounts $(IDIR_BASE)/etc/mtab
- rm -rf $(IDIR_BASE)/var
+ rm -f $(IDIR_BASE)/var
ln -sf /tmp $(IDIR_BASE)/var
-find $(IDIR_BASE) -type d -name CVS | xargs rm -rf
-find $(IDIR_BASE) -type d -name .svn | xargs rm -rf
-find $(IDIR_BASE) -name '.#*' | xargs rm -f
mkdir -p $(IDIR_BASE)/etc
- -grep \^BR2_SYSCONF $(TOPDIR)/.config > $(IDIR_BASE)/etc/sysconf
$(IPKG_BUILD) $(IDIR_BASE) $(PACKAGE_DIR)
$(IPKG_UCLIBC):