summaryrefslogtreecommitdiffstats
path: root/openwrt/package/autossh/Makefile
diff options
context:
space:
mode:
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>2006-10-07 11:57:20 +0000
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>2006-10-07 11:57:20 +0000
commit725611a466f2edf12f809d22339b22223af4afe7 (patch)
tree4b825dc642cb6eb9a060e54bf8d69288fbee4904 /openwrt/package/autossh/Makefile
parentf4dd5a6d7c4ebea48cd6292744cb9def6037de80 (diff)
move old kamikaze out of trunk - will put buildroot-ng in there as soon as all the developers are ready
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@4944 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'openwrt/package/autossh/Makefile')
-rw-r--r--openwrt/package/autossh/Makefile39
1 files changed, 0 insertions, 39 deletions
diff --git a/openwrt/package/autossh/Makefile b/openwrt/package/autossh/Makefile
deleted file mode 100644
index 2d6e53901..000000000
--- a/openwrt/package/autossh/Makefile
+++ /dev/null
@@ -1,39 +0,0 @@
-# $Id$
-#
-# Adjust SSH below to suit.
-#
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=autossh
-PKG_VERSION:=1.3
-PKG_RELEASE:=1
-PKG_MD5SUM:=0e7ec62eeca5d1b197f3ef2d0f0d417f
-PKG_SOURCE_URL:=http://www.harding.motd.ca/autossh
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tgz
-PKG_CAT:=zcat
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
-
-VER=1.3
-SSH=/usr/bin/ssh
-
-include $(TOPDIR)/package/rules.mk
-
-$(eval $(call PKG_template,AUTOSSH,$(PKG_NAME),$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
-
-$(PKG_BUILD_DIR)/.configured:
- cp $(PKG_BUILD_DIR)/Makefile.linux $(PKG_BUILD_DIR)/Makefile
- touch $@
-
-$(PKG_BUILD_DIR)/.built:
- $(MAKE) -C $(PKG_BUILD_DIR) \
- CC=$(TARGET_CC) CFLAGS="$(TARGET_CFLAGS) -Wall -D\"SSH_PATH=\\\"$(SSH)\\\"\" -D\"VER=\\\"$(PKG_VERSION)\\\"\"" \
- BINDIR=/usr/bin MANDIR=/usr/man
- touch $@
-
-$(IPKG_AUTOSSH):
- mkdir -p $(IDIR_AUTOSSH)/usr/bin
- cp $(PKG_BUILD_DIR)/$(PKG_NAME) $(IDIR_AUTOSSH)/usr/bin/
- $(RSTRIP) $(IDIR_AUTOSSH)
- $(IPKG_BUILD) $(IDIR_AUTOSSH) $(PACKAGE_DIR)