summaryrefslogtreecommitdiffstats
path: root/openwrt/package/arptables
diff options
context:
space:
mode:
authornico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-03-06 12:03:54 +0000
committernico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-03-06 12:03:54 +0000
commiteba4b4bcfc49afc8a3d1649751765f1e3285db65 (patch)
treea0d55a1af9452553547e40d42830c4669d9943d3 /openwrt/package/arptables
parent89c4c9dca9c9b471f5e9361efa5f39cb8e80f392 (diff)
Add package install dependencies (don't install a package if it's already installed)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@315 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'openwrt/package/arptables')
-rw-r--r--openwrt/package/arptables/Makefile7
1 files changed, 5 insertions, 2 deletions
diff --git a/openwrt/package/arptables/Makefile b/openwrt/package/arptables/Makefile
index d6af30f33..03c6322fe 100644
--- a/openwrt/package/arptables/Makefile
+++ b/openwrt/package/arptables/Makefile
@@ -34,10 +34,13 @@ $(PKG_IPK): $(PKG_BUILD_DIR)/arptables
mkdir -p $(PACKAGE_DIR)
$(IPKG_BUILD) $(PKG_IPK_DIR) $(PACKAGE_DIR)
+$(IPKG_STATE_DIR)/info/arptables.list: $(PKG_IPK)
+ $(IPKG) install $(PKG_IPK)
+
source: $(DL_DIR)/$(PKG_SOURCE)
prepare: $(PKG_BUILD_DIR)/.unpacked
compile: $(PKG_IPK)
-install:
- $(IPKG) install $(PKG_IPK)
+install: $(IPKG_STATE_DIR)/info/arptables.list
+
clean:
rm -rf $(PKG_BUILD_DIR)