summaryrefslogtreecommitdiffstats
path: root/openwrt/package/Makefile
diff options
context:
space:
mode:
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-04-20 17:01:30 +0000
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-04-20 17:01:30 +0000
commitd4acdafcf724057bc9b718170c54b420f46c40b4 (patch)
treed54625559910142e0895d8a2318d003de21a286c /openwrt/package/Makefile
parentb91216ac5fe33ba6166ab40915fdb8040f470b4e (diff)
add openwrt image builder to sdk
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@688 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'openwrt/package/Makefile')
-rw-r--r--openwrt/package/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/openwrt/package/Makefile b/openwrt/package/Makefile
index bd938800d..4008d434c 100644
--- a/openwrt/package/Makefile
+++ b/openwrt/package/Makefile
@@ -66,6 +66,8 @@ package-$(BR2_PACKAGE_LIBPQ) += postgresql
DEV_LIBS:=tcp_wrappers glib ncurses openssl pcre popt zlib libnet libpcap mysql postgresql iptables matrixssl lzo gmp fuse portmap libelf
DEV_LIBS_COMPILE:=$(patsubst %,%-compile,$(DEV_LIBS))
+SDK_DEFAULT_PACKAGES:=busybox dnsmasq iptables wireless-tools dropbear bridge
+SDK_DEFAULT_COMPILE:=$(patsubst %,%-compile,$(SDK_DEFAULT_PACKAGES))
all: compile install
clean: $(patsubst %,%-clean,$(package-) $(package-y) $(package-m)) linux-clean
@@ -106,7 +108,7 @@ ifeq ($(BR2_PACKAGE_SNORT_PGSQL),y)
snort-compile: postgresql-compile
endif
-sdk-compile: $(DEV_LIBS_COMPILE)
+sdk-compile: $(DEV_LIBS_COMPILE) $(SDK_DEFAULT_COMPILE)
$(patsubst %,%-prepare,$(package-y) $(package-m) $(package-)): linux-install
%-prepare: