summaryrefslogtreecommitdiffstats
path: root/openwrt/package/Makefile
diff options
context:
space:
mode:
authornico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-09-08 22:01:19 +0000
committernico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-09-08 22:01:19 +0000
commitbd2218a04ffa7abbbcda591b53d526d6e8eba605 (patch)
tree0989a9c3ae1610495bfad510d17427982da59c16 /openwrt/package/Makefile
parent1739772b6f5411320fa0e11d5aa70634cd406d9b (diff)
add rrdtool1 (v1.0.x) and enable it by default,
disable rrdtool (v1.2.x), change Maintainer in control files, tweak Makefiles git-svn-id: svn://svn.openwrt.org/openwrt/trunk@1881 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'openwrt/package/Makefile')
-rw-r--r--openwrt/package/Makefile7
1 files changed, 7 insertions, 0 deletions
diff --git a/openwrt/package/Makefile b/openwrt/package/Makefile
index e078d1880..cdc592bdd 100644
--- a/openwrt/package/Makefile
+++ b/openwrt/package/Makefile
@@ -135,6 +135,7 @@ package-$(BR2_PACKAGE_ROBOCFG) += robocfg
package-$(BR2_PACKAGE_RP_PPPOE) += rp-pppoe
package-$(BR2_PACKAGE_RRDCOLLECT) += rrdcollect
package-$(BR2_COMPILE_RRDTOOL) += rrdtool
+package-$(BR2_COMPILE_RRDTOOL1) += rrdtool1
package-$(BR2_PACKAGE_RSYNC) += rsync
package-$(BR2_PACKAGE_SABLEVM) += sablevm
package-$(BR2_PACKAGE_SABLEVM_CLASSPATH) += sablevm-classpath
@@ -230,8 +231,14 @@ portmap-compile: tcp_wrappers-compile
postgresql-compile: zlib-compile
ppp-compile: linux-atm-compile
quagga-compile: readline-compile ncurses-compile
+ifneq ($(BR2_PACKAGE_LIBRRD),)
rrdcollect-compile: rrdtool-compile
+endif
+ifneq ($(BR2_PACKAGE_LIBRRD1),)
+rrdcollect-compile: rrdtool1-compile
+endif
rrdtool-compile: cgilib-compile freetype-compile libart-compile libpng-compile
+rrdtool1-compile: zlib-compile
rsync-compile: popt-compile
samba-compile: cups-compile
screen-compile: ncurses-compile