summaryrefslogtreecommitdiffstats
path: root/openwrt/package/Makefile
diff options
context:
space:
mode:
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-10-22 15:10:20 +0000
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-10-22 15:10:20 +0000
commitbab4efad53ecef261da2a6b6fc4cd1e834636da6 (patch)
treec78be46e0bb41bb4234916f23d9a6cee9a37410c /openwrt/package/Makefile
parentcf904085d9b7aaf9ebe76fbe682b7fd2c1a4447f (diff)
make log output a bit nicer
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@2241 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'openwrt/package/Makefile')
-rw-r--r--openwrt/package/Makefile20
1 files changed, 15 insertions, 5 deletions
diff --git a/openwrt/package/Makefile b/openwrt/package/Makefile
index 0bddabbc8..9053acb37 100644
--- a/openwrt/package/Makefile
+++ b/openwrt/package/Makefile
@@ -442,30 +442,40 @@ $(TARGET_DIR):
%-prepare: $(STAMP_DIR) $(TARGET_DIR)
@[ -f $(STAMP_DIR)/.$@ ] || { \
- $(TRACE) package/$(patsubst %-prepare,%,$@)/prepare; \
+ $(START_TRACE) "package/$(patsubst %-prepare,%,$@)/prepare: "; \
$(MAKE) -C $(patsubst %-prepare,%,$@) prepare; \
+ $(CMD_TRACE) " done"; \
+ $(END_TRACE); \
}
@touch $(STAMP_DIR)/.$@
%-compile:
@[ -f $(STAMP_DIR)/.$@ ] || { \
- $(TRACE) package/$(patsubst %-compile,%,$@)/compile; \
+ $(START_TRACE) "package/$(patsubst %-compile,%,$@)/compile: "; \
$(MAKE) -C $(patsubst %-compile,%,$@) compile; \
+ $(CMD_TRACE) " done"; \
+ $(END_TRACE); \
}
@touch $(STAMP_DIR)/.$(patsubst %-compile,%,$@)-prepare
@touch $(STAMP_DIR)/.$@
%-install: %-compile
- @$(TRACE) package/$(patsubst %-install,%,$@)/install
+ @$(START_TRACE) "package/$(patsubst %-install,%,$@)/install: "
@$(MAKE) -C $(patsubst %-install,%,$@) install
+ @$(CMD_TRACE) " done"
+ @$(END_TRACE)
%-rebuild:
- @$(TRACE) package/$(patsubst %-rebuild,%,$@)/rebuild
+ @$(START_TRACE) "package/$(patsubst %-rebuild,%,$@)/rebuild: "
@rm -f $(STAMP_DIR)/.$(patsubst %-rebuild,%,$@)-*
$(MAKE) -C $(patsubst %-rebuild,%,$@) rebuild
+ @$(CMD_TRACE) " done"
+ @$(END_TRACE)
%-clean:
- @$(TRACE) package/$(patsubst %-clean,%,$@)/clean
+ @$(START_TRACE) "package/$(patsubst %-clean,%,$@)/clean: "
@$(MAKE) -C $(patsubst %-clean,%,$@) clean
@rm -f $(STAMP_DIR)/.$(patsubst %-clean,%,$@)-*
+ @$(CMD_TRACE) " done"
+ @$(END_TRACE)