summaryrefslogtreecommitdiffstats
path: root/openwrt/package/Makefile
diff options
context:
space:
mode:
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-04-10 18:19:34 +0000
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-04-10 18:19:34 +0000
commita496658829c7377f1166e9efa82759e41f4e9b47 (patch)
treed63e48db7c27d0dafc035171a68853d08134706c /openwrt/package/Makefile
parentca9105dabb83eecf7d89f8542559d9d72610028e (diff)
add asterisk
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@611 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'openwrt/package/Makefile')
-rw-r--r--openwrt/package/Makefile10
1 files changed, 10 insertions, 0 deletions
diff --git a/openwrt/package/Makefile b/openwrt/package/Makefile
index 743d2dfcd..23fefcd0c 100644
--- a/openwrt/package/Makefile
+++ b/openwrt/package/Makefile
@@ -6,6 +6,7 @@ package-y:=openwrt
package-$(BR2_PACKAGE_AICCU) += aiccu
package-$(BR2_PACKAGE_ARPTABLES) += arptables
package-$(BR2_PACKAGE_ARPWATCH) += arpwatch
+package-$(BR2_PACKAGE_ASTERISK) += asterisk
package-$(BR2_PACKAGE_BRIDGE) += bridge
package-$(BR2_PACKAGE_BUSYBOX) += busybox
package-$(BR2_PACKAGE_BWM) += bwm
@@ -69,6 +70,15 @@ install: $(patsubst %,%-install,$(package-y))
ifeq ($(BR2_PACKAGE_OPENVPN_LZO),y)
openvpn-compile: lzo-compile
endif
+ifneq ($(BR2_PACKAGE_ASTERISK_SPEEX),)
+asterisk-compile: speex-compile
+endif
+ifneq ($(BR2_PACKAGE_ASTERISK_PGSQL),)
+asterisk-compile: postgresql-compile
+endif
+ifneq ($(BR2_PACKAGE_ASTERISK_MYSQL),)
+asterisk-compile: mysql-compile
+endif
openswan-compile: gmp-compile
nocatsplash-compile: glib-compile