summaryrefslogtreecommitdiffstats
path: root/obsolete-buildroot/sources/openwrt/ipkg/libpthread/CONTROL/rules
diff options
context:
space:
mode:
authormbm <mbm@3c298f89-4303-0410-b956-a3cf2f4a3e73>2004-08-27 00:42:33 +0000
committermbm <mbm@3c298f89-4303-0410-b956-a3cf2f4a3e73>2004-08-27 00:42:33 +0000
commitf0c8400658ac5b039bb48dbb74b02f75d52b9723 (patch)
tree7ef2c062b8733bbd08473f6c2bed78c7ad9708d1 /obsolete-buildroot/sources/openwrt/ipkg/libpthread/CONTROL/rules
parentaa210b58909434abaa63a7a6cd898a43ba61c3f3 (diff)
various patches
nico: buildroot-20040825-kmodules.patch.txt buildroot-20040825-tcpdump.patch.txt buildroot-20040825-libpcap.patch.txt buildroot-20040825-libpthread.patch.txt buildroot-20040825-fprobe.patch.txt buildroot-20040825-pptp-client.patch.txt twolife: iproute2.patch.txt git-svn-id: svn://svn.openwrt.org/openwrt/trunk@149 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'obsolete-buildroot/sources/openwrt/ipkg/libpthread/CONTROL/rules')
-rwxr-xr-xobsolete-buildroot/sources/openwrt/ipkg/libpthread/CONTROL/rules34
1 files changed, 34 insertions, 0 deletions
diff --git a/obsolete-buildroot/sources/openwrt/ipkg/libpthread/CONTROL/rules b/obsolete-buildroot/sources/openwrt/ipkg/libpthread/CONTROL/rules
new file mode 100755
index 000000000..9f742d4de
--- /dev/null
+++ b/obsolete-buildroot/sources/openwrt/ipkg/libpthread/CONTROL/rules
@@ -0,0 +1,34 @@
+#!/usr/bin/make -f
+
+ifeq ($(strip $(TOPDIR)),)
+TOPDIR := $(shell pwd)/../../../..
+endif
+
+
+# variables extracted from $(TOPDIR)/Makefile
+ARCH:= mipsel
+STAGING_DIR=$(TOPDIR)/build_$(ARCH)/staging_dir
+REAL_GNU_TARGET_NAME=$(ARCH)-linux-uclibc
+TARGET_CROSS=$(STAGING_DIR)/bin/$(REAL_GNU_TARGET_NAME)-
+STRIP=$(TARGET_CROSS)strip --remove-section=.comment --remove-section=.note
+# could be better if replaced with:
+#include $(TOPDIR)/Config
+
+
+PACKAGE := libpthread
+
+MY_INSTALL_DIR := /tmp/$(PACKAGE)
+
+
+build:
+
+
+install:
+ rm -rf $(MY_INSTALL_DIR)
+ install -m0755 -d $(MY_INSTALL_DIR)/lib
+ install -m0755 $(STAGING_DIR)/$(REAL_GNU_TARGET_NAME)/lib/libpthread-0.9.26.so $(MY_INSTALL_DIR)/lib
+ $(STRIP) $(MY_INSTALL_DIR)/lib/libpthread*.so*
+ ln -fs libpthread-0.9.26.so $(MY_INSTALL_DIR)/lib/libpthread.so.0
+
+clean:
+