summaryrefslogtreecommitdiffstats
path: root/obsolete-buildroot/make/sched-mod.mk
diff options
context:
space:
mode:
authorgroz <groz@3c298f89-4303-0410-b956-a3cf2f4a3e73>2004-06-08 08:38:06 +0000
committergroz <groz@3c298f89-4303-0410-b956-a3cf2f4a3e73>2004-06-08 08:38:06 +0000
commit2901ca675b2efbd0caaed3ec305fb913fe80dfdf (patch)
tree8cade8d6b5e8250d5e1a212bef319b277b7e2f93 /obsolete-buildroot/make/sched-mod.mk
parent06716090127eff94b890e22d8677abe0443c107b (diff)
Integrated the -ipk target into the system for building ipkg files
Added wshaper.mk oidentd.mk sched-modules.mk git-svn-id: svn://svn.openwrt.org/openwrt/trunk@67 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'obsolete-buildroot/make/sched-mod.mk')
-rw-r--r--obsolete-buildroot/make/sched-mod.mk44
1 files changed, 44 insertions, 0 deletions
diff --git a/obsolete-buildroot/make/sched-mod.mk b/obsolete-buildroot/make/sched-mod.mk
new file mode 100644
index 000000000..0a27d7f27
--- /dev/null
+++ b/obsolete-buildroot/make/sched-mod.mk
@@ -0,0 +1,44 @@
+######################################################
+#
+# A really simple example that doesn't actually build anything
+# It'll fetch a package from another repository for inclusion
+# into our final list
+# Using one from the openwrt home as an example
+#
+######################################################
+
+
+SCHEDM=sched-modules
+
+SCHEDM_TARGET=sched-modules_2.4.20_mipsel.ipk
+SCHEDM_SITE=http://openwrt.rozeware.bc.ca/ipkg-dev
+SCHEDM_SOURCE=openwrt-kmodules.tar.bz2
+SCHEDMIPK_SRC=sched-modules-ipk.tgz
+
+
+sched-modules-ipk: $(BUILD_DIR)/$(SCHEDM_TARGET)
+
+
+# fetch the ipkg rules stuff
+$(DL_DIR)/$(SCHEDMIPK_SRC) :
+ $(WGET) -P $(DL_DIR) $(SCHEDM_SITE)/$(SCHEDMIPK_SRC)
+
+#make sure we have a directory to extract to
+$(BUILD_DIR)/$(SCHEDM) :
+ mkdir $(BUILD_DIR)/$(SCHEDM)
+
+#extract the archive
+$(BUILD_DIR)/$(SCHEDM)/modules/2.4.20/net/sched/cls_fw.o : $(BUILD_DIR)/$(SCHEDM) $(SCHEDM_SOURCE)
+ tar -C $(BUILD_DIR)/$(SCHEDM) -jxf $(SCHEDM_SOURCE)
+
+# extract the ipkg overlay
+$(BUILD_DIR)/$(SCHEDM)/ipkg/control : $(DL_DIR)/$(SCHEDMIPK_SRC) $(BUILD_DIR)/$(SCHEDM)/modules/2.4.20/net/sched/cls_fw.o
+ tar -C $(BUILD_DIR)/$(SCHEDM) -zxf $(DL_DIR)/$(SCHEDMIPK_SRC)
+
+# now that we have it all in place, just build it
+$(BUILD_DIR)/$(SCHEDM_TARGET): $(BUILD_DIR)/$(SCHEDM)/ipkg/control $(BUILD_DIR)/$(SCHEDM)/modules/2.4.20/net/sched/cls_fw.o
+ cd $(BUILD_DIR)/$(SCHEDM); ipkg-buildpackage -c
+
+
+
+