summaryrefslogtreecommitdiffstats
path: root/obsolete-buildroot/Makefile
diff options
context:
space:
mode:
authormbm <mbm@3c298f89-4303-0410-b956-a3cf2f4a3e73>2004-08-20 05:39:59 +0000
committermbm <mbm@3c298f89-4303-0410-b956-a3cf2f4a3e73>2004-08-20 05:39:59 +0000
commit86697678e93f1a432db4b340099a6b34740495f6 (patch)
treeb03e6465ab55acd0d11507bcb584626ed5e48c17 /obsolete-buildroot/Makefile
parent89d5f1345fed2acdc703cc3a51e25662097a9c6e (diff)
fix zlib; add dropbear ipkg
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@139 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'obsolete-buildroot/Makefile')
-rw-r--r--obsolete-buildroot/Makefile10
1 files changed, 6 insertions, 4 deletions
diff --git a/obsolete-buildroot/Makefile b/obsolete-buildroot/Makefile
index e534b44c4..0b67b1539 100644
--- a/obsolete-buildroot/Makefile
+++ b/obsolete-buildroot/Makefile
@@ -97,7 +97,7 @@ INSTALL_LIBGCJ:=false
#############################################################
TARGETS:=host-sed openwrt-code.bin
-PACKAGES:=oidentd iproute2 sched-modules wshaper zlib openssl openssh pppoecd
+PACKAGES:=oidentd iproute2 sched-modules wshaper zlib openssl openssh pppoecd dropbear
#############################################################
#
@@ -192,9 +192,11 @@ world: $(DL_DIR) $(TARGETS_SOURCE) $(BUILD_DIR) $(STAGING_DIR) $(TARGET_DIR) $(T
packages: ipkg-utils $(PACKAGES_IPK)
-@mkdir -p $(BASE_DIR)/packages
- cd $(BASE_DIR)/packages
- -mv $(BUILD_DIR)/*.ipk .
- $(IPKG_MAKE_INDEX) . > Packages
+ { \
+ cd $(BASE_DIR)/packages; \
+ mv $(BUILD_DIR)/*.ipk .; \
+ $(IPKG_MAKE_INDEX) . > Packages; \
+ }
@echo "ALL DONE."
.PHONY: all world clean dirclean distclean source $(TARGETS) \